Archive for May, 2011

19
May

stunnel and zebedee

   Posted by: admin    in Linux nông dân, Lăng nhăng lít nhít

download http://www.winton.org.uk/zebedee/download.html

server side :

zebedee -s -u # udp mode

zebedee -s # tcp mode

zebedee -s -d -v 5 # d=detach v=verbose

client side :

zebedee 8080:server-ip:80  # listen 8080 forward to server-ip:80

zebedee -u 5353:server-ip:53 -z 0 -k 0 -d -v 5 # z=compress k=encrypt d=detach v=verbose

iptables -t nat -A OUTPUT -p udp -d server-ip –dport 53 -j REDIRECT –to-ports 5353

stunnel

cd /etc/stunnel

openssl req -new -x509 -days 3650 -nodes -out stunnel.pem -keyout stunnel.pem

vi test.conf

cert=/etc/stunnel/stunnel.pem

debug=7

foreground=yes

[test]

accept=2525

connect=25

#stunnel /etc/stunnel/test.conf
client side

cd /etc/stunnel

vi test.conf

debug=7
foreground=yes
client=yes
[test]
accept=local-ip:2525
connect=remoteip:2525
[pop3ssl]
accept=995
connect=110
#stunnel /etc/stunnel/test.conf
16
May

RHEL5 BONDING with 3750 802.3ad

   Posted by: admin    in Linúc ếch bợt

Testing :

modprobe bonding  mode=4 miion=100 xmit_hash_policy=1

ifconfig bond0 192.168.253.101/24 up

ifconfig eth0 down

ifenslave bond0 eth0

ifenslave bond0 eth1

——— sh run ——-

!

interface Port-channel1

description Port channel for RHEL5-Server

switchport access vlan 105

switchport mode access

!

!

interface GigabitEthernet1/0/15

description This port is reversed for RHEL5-Server

switchport access vlan 105

switchport mode access

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet1/0/16

description This port is reversed for RHEL5-Server

switchport access vlan 105

switchport mode access

channel-protocol lacp

channel-group 1 mode active

!

Finalizing :

put in your /etc/modules.conf :

alias bond0 bonding options bond0 mode=4 miimon=100 xmit_hash_policy=1

create ifcfg-bond0 file in /etc/sysconfig/network-scripts directory that looks like this:
DEVICE=bond0
IPADDR=192.168.1.1
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
All interfaces that are part of the trunk, should have SLAVE and MASTER definitions. For example, in the case of RedHat, if you wish to make eth0 and eth1 (or other interfaces) a part of the bonding interface bond0, their config files (ifcfg-eth0, ifcfg-eth1, etc.) should look like this:
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none 

 

4
May

unsupported esx console

   Posted by: admin    in Lăng nhăng lít nhít

  1. alt-f1 (Note: As pointed out below, you will not see your typing on this screen, just trust us, it is there).
  2. unsupported
  3. root pw
  4. vi /etc/inetd.conf
  5. delete the “#” from ssh
  6. kill -HUP ( inetd )
ssh-keygen -t rsa
scp id_rsa.pub user@esxiserver:/vmfs/volumes/datastore1/authorized_keys

login to the esxiserver TSM propmt and add to /etc/rc.local

mkdir /.ssh
cp /vmfs/volumes/datastore1/authorized_keys /.ssh/
chmod -R 600 /.ssh